Solving dependency problems

From MEPIS Documentation Wiki

Jump to: navigation, search

Contents

Introduction

Sometimes dependency problems arise when you try to install a program. You can get a message similar to this:

Unpacking kvirc3 (from .../kvirc3_3.0.1-2_i386.deb) ...
dpkg: dependency problems prevent configuration of kvirc3:
kvirc3 depends on libarts1 (>= 1.3.0); however:
Version of libarts1 on system is 1.2.3-1.
kvirc3 depends on libjack0.80.0-0 (>= 0.98.1); however:
Package libjack0.80.0-0 is not installed.
kvirc3 depends on libqt3c102-mt (>= 3:3.3.3); however:
Version of libqt3c102-mt on system is 3:3.3.2-5.
dpkg: error processing kvirc3 (--install):
dependency problems - leaving unconfigured

As you can see there's a chain of dependency problems that doesn't let the package get installed. You have two tasks: remove the failed installation, and solve the problem.

Remove the failed installation

GUI method (Synaptic)

  1. Open Synaptic
  2. In the Table of Contents to the left, click on "Broken Packages"
  3. Right-click the package, and click on uninstall

Command-line method

  1. Open a terminal
  2. Run as root:
dpkg --configure -a 

This will remove the unconfigured packages.

Solve the problem

Here are your choices:

  • Enable "unstable" sources and try to install from it: apt-get -t unstable install packagename (make sure no important package gets removed).
  • Wait. Sometimes Debian repositories get out of sync, the situation usually gets resolved in one or two days.
  • Use information from Source:Debian_snapshot to enable Debian snapshot repository to install older packages.

FAQ | Main Page

Personal tools
In other languages